A fix has been implemented and we are monitoring the results.
Update
Update
Our engineers have implemented a fix and continue to test internally.
Identified
Identified
Our engineers have identified the source of this issue and are working on fixing it!
Investigating
Investigating
We have received reports of payments intermittently appearing to fail to complete. We are actively looking into this issue and will report back shortly.